I need help troubleshooting my hidden fields (utm_campaign) and AdWords

Hi,

I came aboard a project after all the forms have been created here, and the Google AdWords created. The problem is none of the potential custom url parameters are setup properly, so my boss has little to no data telling her which AdWords campaigns are leading to which form submissions on the site. I am trying to fix this.

Some background…
Our forms from here are added via HTML code. I have added hidden fields for this purpose by

  • creating the custom hidden fields via admin > settings > “Setup custom field for”
  • made one called “utm_campaign”
  • went into one of the web forms, inside of its campaign,
  • added a hidden field
  • chose the field i had created
  • republished the campaign
  • inspected one of the pages with that form to see the hidden field (see: https://snipboard.io/FCq043.jpg )

If i understand correctly, if the url has that custom parameter like https://extraordinaryjourneys.com/?utm_campaign=Luxury_African_Safari then that field should be populated by that url parameter, right?

In this case I am testing simply by pasting in that url which goes to the homepage, which has the form, which has the field, and it does not get any value. Am i missing something?

I understand that the custom parameter is set inside the campaign or the group in AdWords which points to the page with the form with the field, but i am testing manually first, before I go in changing in AdWords. The browser itself nor the form as far as i know don’t know the difference, they only know the url.

So, can you help me see why my hidden field is not getting populated from the custom url parameter?