Can't Delete Opportunities in XML-RPC 'Failed to Invoke Method'

I’m working on a mobile application that needs to be able to delete opportunities in Infusionsoft.

In calling the DataService.delete with the following (slightly modified) data:

‘zGZxxxxxxxB’, ‘Leads’, 11331

and am getting this returned

“code”: 0,
“faultCode”: 0,
“faultString”: “Failed to invoke method delete in class com.infusionsoft.api.xmlrpc.XmlRpcDataService: null”

How do I even start to troubleshoot what might be wrong here?

If the data you are providing is what you are calling, the table name might be wrong. The table to delete from should be “Lead”, not “Leads”.

It’s interesting, and I’ll try that again, but I have to say - when we use the API to ask for a list of tables, there is no table called Lead but there is a table called Leads.

I know in the table list in Infusionsoft’s documentation it says Lead, and we have tried both ways (but maybe last time we tried lead something else was wrong)… Any idea why the Lead table wouldn’t list in the list of tables, though? Or is it called Lead in the API, but that references a table called Leads which is what is actually in the data structure if you query it?

Not sure, I have always based my table info on the table list in the documentation. What is the method you are using to get the table list from the api?

Hey Daniel - first of all - you were right, it is Lead. This was a case of multiple issues (passing ID as string not integer), and at one point changing the table name to Leads worked for us. However, the name is Lead. I also realized that when we were querying tables, we were actually querying endpoints in a 3rd party SDK wrapper, not actually infusionsoft, which is where we were getting Leads as a ‘table’… so, thank you very much - this is solved.